Monday, March 2, 2009

Configuring Cisco Router as a DHCP Server


Thank GOD, atlast i have done it.....lolz. I was trying from last couple of days to configure cisco router as a DHCP server but there were some problems but anyway today i have done with that. Here is the step wise configuration of the Lab, may be it will help someone. so here we go!

Note: connect the devices as shown in the figure

The configuration on cisco router to be DHCP server as follow:

SERVER(config)# interface fasethernet 0/0
SERVER(config-if)# ip address 192.168.1.1 255.255.255.0
SERVER(config-if)# no shutdown
SERVER(config-if)# exit

SERVER(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.99
SERVER(config)# ip dhcp pool mypool
SERVER(config)# network 192.168.1.0 255.255.255.0
SERVER(config)# default-router 192.168.1.1
SERVER(config)# dns-server 192.168.1.1


Now the configuration on the client side is just simple

CLIENT_1(config)# do show ip interface brief
CLIENT_1(config)#interface fastethernet 0/0
CLIENT_1(config-if)# ip address dhcp
CLIENT_1(config-if)# no shutdown


Now wait for the log message on console, if not seen don't worry after a while CLIENT_1 should obtained ip from DHCP Server.

CLIENT_1# show ip interface brief
CLIENT_1# ping 192.168.1.1


You can check the DHCP bindings by a command

CLIENT_1# show ip dhcp bindings

The output of my lab for this bindings command is as follow:
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.1.100 0001.4303.C501 -- Automatic
192.168.1.101 0004.9A66.B101 -- Automatic
192.168.1.102 000A.41D2.1543 -- Automatic


The same commands are on CLIENT_2 as we did on CLIENT_1. For pc just check the option (ip configuration......DHCP).

Enjoy it!

3 comments:

nayyares said...

great man, i am proud at you !

ninest123 said...

replica watches, ugg boots, ralph lauren pas cher, oakley sunglasses, louis vuitton, nike roshe run, chanel handbags, burberry, kate spade outlet, louis vuitton outlet, nike outlet, longchamp, louboutin shoes, gucci outlet, ray ban sunglasses, air jordan pas cher, nike free, jordan shoes, sac longchamp, uggs on sale, louboutin, nike free, cheap oakley sunglasses, nike air max, prada outlet, air max, christian louboutin outlet, tory burch outlet, longchamp pas cher, polo ralph lauren outlet, ugg boots, polo ralph lauren outlet, louis vuitton, replica watches, nike air max, louboutin pas cher, oakley sunglasses, tiffany jewelry, oakley sunglasses, ray ban sunglasses, louis vuitton, prada handbags, michael kors, ray ban sunglasses, louis vuitton outlet, louboutin outlet, longchamp outlet, oakley sunglasses, longchamp outlet, tiffany and co

ninest123 said...

michael kors, hermes, michael kors outlet, converse pas cher, vans pas cher, true religion jeans, michael kors, nike roshe, tn pas cher, michael kors outlet, michael kors outlet, michael kors outlet, north face, nike air max, mulberry, coach outlet, nike air max, ugg boots, nike free run uk, north face, replica handbags, nike air max, sac guess, michael kors outlet, lululemon, true religion jeans, abercrombie and fitch, nike blazer, hollister pas cher, michael kors, new balance pas cher, hogan, oakley pas cher, kate spade handbags, true religion outlet, coach outlet, air force, burberry outlet online, vanessa bruno, ugg boots, timberland, ray ban pas cher, true religion jeans, coach purses, lacoste pas cher, hollister, burberry, ralph lauren uk, ray ban uk, michael kors